[sip-comm-dev] I cant send video on Ubuntu version (maybe problem with h.264)

pmoreno at gbt.tfo.upm.es pmoreno at gbt.tfo.upm.es
Fri Jul 24 15:07:14 CEST 2009


Hello,

I'm working with SIPCommunicator on Ubuntu version. When I try to
establish a call with another user I can see his video but my video isn't
transmmited. I've been wondering why and I think that the reason is the
H.264 codec, because I get this session description of invite request
(catch with wireshark):

Session Description Protocol
Session Description Protocol Version (v): 0
Owner/Creator, Session Id (o): pmoreno 0 0 IN IP4 138.4.10.142
Connection Information (c): IN IP4 138.4.10.142
Time Description, active time (t): 0 0
Media Description, name and address (m): audio 5000 RTP/AVP 0 8 97 3 5 4
Media Attribute (a): rtpmap:4 G723/8000
Media Attribute (a): fmtp:4 annexa=no;bitrate=6.3
Media Description, name and address (m): video 5002 RTP/AVP 99 34 26 31
Media Attribute (a): rtpmap:99 H264/90000
Media Attribute (a): fmtp:99 packetization-mode=1
Media Attribute (a): recvonly

Why "recvonly"?? It should be "sendrecv", isn't it?

I've missed any specific packet on ubuntu, which is not neccesary on WinXP?

Can anybody help me? I've very stuck with this problem

Thanks a lot in advance

Pedro


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe at sip-communicator.dev.java.net
For additional commands, e-mail: dev-help at sip-communicator.dev.java.net





More information about the dev mailing list