[sip-comm-dev] [GSoC09] Java interface for Mac OS X's Growl

Lubomir Marinov lubomir.marinov at gmail.com
Tue Jul 21 11:49:48 CEST 2009


Hi Egidijus,

> I have tried it on my girlfriends 64bit Mac and it
> didn't work. It complained that  "... libgrowl.dylib: no matching
> architecture in universal wrapper".
>
> However, the java test application works just fine on 64bit Mac when it is
> run from console, so I guess it is a problem of Jar Bundler that I use. So I
> am curious if the lack of 64bit library may cause any problems in SC?

I'm not really sure whether "it didn't work" or "the java test
application works just fine"... I guess it may be appropriate for SIP
Communicator on 64-bit to revert to non-Growl means when it detects at
runtime that Growl isn't really available.

> I see
> that AEGetURLEventHandler library is compiled for i386, x86_64 , and PPC.

AEGetURLEventHandler has to be compiled for x86_64 because it's an
agent i.e. if the VM is 64-bit, it will fail to load the agent and
will, consequently, exit thus preventing SIP Communicator from
starting at all. Since it shouldn't be the case for Growl, I suppose
the lack of 64-bit support isn't that vital.

Regards,
Lubomir

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe at sip-communicator.dev.java.net
For additional commands, e-mail: dev-help at sip-communicator.dev.java.net





More information about the dev mailing list