[Issue 502] New - Do not use jdic when running Java 6

emcho at dev.java.net emcho at dev.java.net
Tue Dec 2 13:19:00 CET 2008


https://sip-communicator.dev.java.net/issues/show_bug.cgi?id=502
                 Issue #|502
                 Summary|Do not use jdic when running Java 6
               Component|sip-communicator
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|ENHANCEMENT
                Priority|P3
            Subcomponent|development
             Assigned to|issues at sip-communicator
             Reported by|emcho






------- Additional comments from emcho at dev.java.net Tue Dec  2 12:18:58 +0000 2008 -------
Java6 includes most of the features that we use from jdic so we don't really
need the latter when running under J6. Moreover, using jdic together with java6
seems to be causing issues on mac and with open jdk.

Therefore, we need to make sure that jdic is only used if and only if we are
running a java version that is earlier that j6.




More information about the issues mailing list