[sip-comm-issues] [Issue 533] New - Plug-in ConfigurationForm buttons not properly enabled

lubomir_m at dev.java.net lubomir_m at dev.java.net
Tue Dec 16 21:58:45 CET 2008


https://sip-communicator.dev.java.net/issues/show_bug.cgi?id=533
                 Issue #|533
                 Summary|Plug-in ConfigurationForm buttons not properly enabled
               Component|sip-communicator
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|development
             Assigned to|issues at sip-communicator
             Reported by|lubomir_m






------- Additional comments from lubomir_m at dev.java.net Tue Dec 16 20:58:43 +0000 2008 -------
The Plug-ins ConfigurationForm contains a table on the left and a column of
buttons on the right. These buttons are supposed to act on the selected plug-ins
in the table. So they should be enabled/disabled according to whether their
associated action can be executed on the current selection. The problem is that,
for example, the buttons are all enabled when the Plug-ins ConfigurationForm
initially shows up. Another example is that if "Show system bundles" is checked
and a specific plug-in is selected, the buttons are properly enabled/disabled
but then unchecking "Show system bundles" which leaves no bundles in the table
leaves the buttons enabled/disabled as if there was a selection.

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe at sip-communicator.dev.java.net
For additional commands, e-mail: issues-help at sip-communicator.dev.java.net





More information about the issues mailing list