[jitsi-issues] [JIRA] Closed: (JITSI-975) Jabber login failed

emcho (JIRA) jira-no-reply at java.net
Sat Aug 20 12:41:36 CEST 2011


     [ http://java.net/jira/browse/JITSI-975?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

emcho closed JITSI-975.
-----------------------

    Resolution: Invalid

Hello and thanks for your report!

As it was already explained on the IRC channel, there must be an issue with your configuration. Please delete your jabber account and then recreate it again by _only_ entering your jid and password and avoid modifying any ports. Also make sure that your that the "Proxy Type" in your "Global Proxy" configuration is set to NONE.

Note however that as our "Bugs and Issues" page [0] explains, we expect reports to  be submitted in the issue tracker once they have been discussed and confirmed as such on our dev mailing list [1]. This is really important to us and we've tried to made it clear throughout the site. 

I'll therefore be marking this issue as Invalid. Feel free to repost on dev at jitsi.java.net and we will of course reopen it if necessary.

[0] http://www.jitsi.org/index.php/Development/BugsAndIssues
[1] dev at jitsi.java.net

P.S. On a side note, we would be interested to know how you reached the issue tracker without seeing any of the notes where we ask users not to submit issues without discussing them with the developers first.

> Jabber login failed
> -------------------
>
>                 Key: JITSI-975
>                 URL: http://java.net/jira/browse/JITSI-975
>             Project: jitsi
>          Issue Type: Bug
>          Components: development
>    Affects Versions: current
>         Environment: Operating-System: Aptosid (debian-sid with KDE-SC) 
> Hardware: Compaq 615
> web-router: AVM-FritzBox 7170
> Java-version: "1.6.0_18"
> OpenJDK Runtime Environment (IcedTea6 1.8.9) (6b18-1.8.9-0.1)
> OpenJDK Server VM (build 16.0-b13, mixed mode)
> Jitsi-Version: 1.0-beta1-nightly.build.3593
>            Reporter: esefchen
>            Priority: Blocker
>   Original Estimate: 2 hours
>  Remaining Estimate: 2 hours
>
> I have got a problem trying to login with my jabber-accounts. My jabber-accounts at jabber.org and web.de works correctly with the clients Kopete and Pidgin. But in Jitsi I always get the following error message when I try to login.:
> > An error has occured at login ... Configurtion error. please ckeck
> > your settings!
> >
> > net.java.sip.communicator.service.protocol.OperationFailedException:
> > Wrong proxy port, null does not represent an integer
> >     at
> > net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:631)
> >     at
> > net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:358)
> >     at
> > net.java.sip.communicator.impl.gui.main.login.LoginManager$RegisterProvider.run(LoginManager.java:405)
> > Caused by: java.lang.NumberFormatException: null
> >     at java.lang.Integer.parseInt(Integer.java:443)
> >     at java.lang.Integer.parseInt(Integer.java:514)
> >     at
> > net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:626)
> >     ... 2 more
> I have enabled the ports 5061 with UDP and 5222 with TCP in the FritzBox-configuration Portal. The port 5061 I need to enabled to be able to make SIP-calls with Twinkel and Linphone.
> I didn't made any entry and any changes in the proxy-configuration, because I have no proxy-account. And I don't need a proxy in Kopete and Pidgin to send and receive messages in XMPP with my web.de and jabber.org- accounts.
> I wrote about this already in the mailling-list and teh IRC-chat some month ago, but I don't got any usefull help until now.
> SIP-call is also not working to me in Jitsi. I can do SIP-calls in Twinkel and Linphone only by using a STUN-server.
> So I set the priority of this issue on "Blocker", because as long as this error occured Jitsi is not usable for me in any way. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://java.net/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        




More information about the issues mailing list