[jitsi-issues] [JIRA] Closed: (JITSI-787) update system is insecure

ibauersachs (JIRA) jira-no-reply at java.net
Wed Jan 9 19:28:52 CET 2013


     [ http://java.net/jira/browse/JITSI-787?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

ibauersachs closed JITSI-787.
-----------------------------

         Assignee:     (was: jitsi-issues)
    Fix Version/s:     (was: 2.0)
       Resolution: Fixed

- update_link is on https
- Windows and Mac builds are signed
- The statement about about the Updater using a null-validator is wrong

This leaves linux, but work to publish it in the official distro-repositories is in the works.

> update system is insecure
> -------------------------
>
>                 Key: JITSI-787
>                 URL: http://java.net/jira/browse/JITSI-787
>             Project: jitsi
>          Issue Type: Improvement
>          Components: deployment
>    Affects Versions: future
>         Environment: Operating System: All
> Platform: All
>            Reporter: the_real_andrew
>
> The updatecheck plugin has two issues;
> 1) It checks download_link=http\://download.sip-communicator.org which is not
> ssl, so anyone can fake the site and dns and send the client to a false site. 
> Suggested fix is to setup an ssl cert on download.sip-communicator.org, and make
> the updatecheck plugin verify the cert (put the ssl fingerprint in the code or
> use oscp urls to validate the cert and CA).  It appears the
> UpdateCheckActivator.java include a dummytrustmanager for automatically
> approving any cert.  This seems bad.
> 2) The releases aren't signed, so there's no way to know that this is really the
> right package and url to get the update.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://java.net/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        




More information about the issues mailing list