[jitsi-issues] Jitsi java.lang.IllegalArgumentException

Pavel Alexeev forum at hubbitus.com.ru
Sat Mar 30 16:47:21 CET 2013


Hello, list.

I have tried Jitsi on Fedora:
$ rpm -q jitsi
jitsi-2.1.4524.10619-6.1.x86_64

But have no luck make call unfortunately. Instead I got exception.
In log I see:
java.lang.IllegalArgumentException: No "c=" field in the following media
description nor in the enclosing session:
m=video 0 RTP/AVP 105 99
a=sendrecv

    at
net.java.sip.communicator.impl.protocol.sip.sdp.SdpUtils.extractDefaultTarget(SdpUtils.java:1041)
    at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.doNonSynchronisedProcessAnswer(CallPeerMediaHandlerSipImpl.java:914)
    at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.processAnswer(CallPeerMediaHandlerSipImpl.java:865)
    at
net.java.sip.communicator.impl.protocol.sip.CallPeerMediaHandlerSipImpl.processAnswer(CallPeerMediaHandlerSipImpl.java:839)
    at
net.java.sip.communicator.impl.protocol.sip.CallPeerSipImpl.processSessionProgress(CallPeerSipImpl.java:761)
    at
net.java.sip.communicator.impl.protocol.sip.OperationSetBasicTelephonySipImpl.processSessionProgress(OperationSetBasicTelephonySipImpl.java:742)
    at
net.java.sip.communicator.impl.protocol.sip.OperationSetBasicTelephonySipImpl.processResponse(OperationSetBasicTelephonySipImpl.java:423)
    at
net.java.sip.communicator.impl.protocol.sip.ProtocolProviderServiceSipImpl.processResponse(ProtocolProviderServiceSipImpl.java:660)
    at
net.java.sip.communicator.impl.protocol.sip.SipStackSharing.processResponse(SipStackSharing.java:704)
    at gov.nist.javax.sip.EventScanner.deliverEvent(EventScanner.java:296)
    at
gov.nist.javax.sip.SipProviderImpl.handleEvent(SipProviderImpl.java:196)
    at
gov.nist.javax.sip.DialogFilter.processResponse(DialogFilter.java:1480)
    at
gov.nist.javax.sip.stack.SIPClientTransaction.inviteClientTransaction(SIPClientTransaction.java:878)
    at
gov.nist.javax.sip.stack.SIPClientTransaction.processResponse(SIPClientTransaction.java:548)
    at
gov.nist.javax.sip.stack.SIPClientTransaction.processResponse(SIPClientTransaction.java:1554)
    at
gov.nist.javax.sip.stack.UDPMessageChannel.processMessage(UDPMessageChannel.java:583)
    at
gov.nist.javax.sip.stack.UDPMessageChannel.processIncomingDataPacket(UDPMessageChannel.java:492)
    at
gov.nist.javax.sip.stack.UDPMessageChannel.run(UDPMessageChannel.java:297)
    at java.lang.Thread.run(Thread.java:722)

Is it bug and should I report it in some place (your site said I must
ask in this list first)?

I have also pcap dump. Please say if I could provide more info or help
to fix this issue.


-- 
With best wishes, Pavel Alexeev (aka Pahan-Hubbitus). For fast contact
with me use jabber: Hubbitus at jabber.ru




More information about the issues mailing list